Tento článek je o tom, jak v Excelu pojmenovat skupinu buněk, a s takto pojmenovanými oblastmi pracovat.

To se může hodit při výpočtech (viz tento článek), ale také při práci s kontingenční tabulkou nebo třeba při ověřování dat.

V Excelu se setkáme se dvěma typy pojmenovaných oblastí, které se ale v použití dost liší.

Prvním typem pojmenované oblasti jsou vložené tabulky - těm se podrobně věnuje tento článek.

Druhým typem pojmenované oblasti jsou oblasti, které uživatel pojmenuje bez vložené tabulky - fakt nevím, jak je lépe nazvat. Těm se věnuje tento článek.

Návod

V tabulce je pět čísel. Tato čísla chceme sečíst a chceme to udělat tak, aby vzorec vypadal takto:

  • =SUMA(scitana_oblast)

místo:

  • =SUMA(A2:A6)

Označíme oblast, o kterou jde, v tomto případě A2 až A6. Pak, bez čehokoliv dalšího, prostě zapíšeme název oblasti sem:

přidání názvu

Zápis potvrdíme entrem. Teď už tedy Excel ví, že se oblast buněk jmenuje "scitana_oblast" a můžeme s ní pracovat a zapsat např.:
  • =PRŮMĚR(scitana_oblast)
nebo:
  • =MAX(scitana_oblast)
atd.

Je možné si všimnout, že při označení příslušné oblasti se nám v levé horní části obrazovky zobrazí její jméno.

Pokud se chceme podívat, které pojmenované oblasti v souboru máme, můžeme se podívat na Vzorce / Správce názvů. Jsou zde vidět jak běžné pojmenované oblasti, tak vložené tabulky.
správce názvů

12 Comments

  1. Už je zaveden pojem „definované názvy“, sic v praxi je výstižnější „pojmenované vzorce“. Dělení a) Vložené pojmenované tabulky (Tabulky?) b) Vlastní názvy bez tabulky – pardon, ale to je nesmysl, který vidím poprvé v životě.

  2. Netvrdím, že to nejde napsat lépe, ale problém je, že Definované názvy pokrývají jak to, co je v tomhle článku, tak vložené tabulky – což je něco, co funguje úplně jinak…

  3. Pořád nerozumím souvislosti definovaných názvů a dalšího mně neznámého pojmu „vložené tabulky“. Ano, kontingenční tabulky (nezmíněny) a Tabulky mají své názvy, v Tabulkách se objevují strukturované odkazy/názvy, ale název má v Excelu kde co (i vložený tvar). Kam podle vašeho dělení spadají názvy vytvářené Excelem (_FiltrDatabaze, Extrakce, Oblast_tisku, …)? Nemluvě o tom, že článek je právě tak dlouhý, aby nemusel zmínit přinejmenším jednu podstatnou věc, a tou je viditelnost (platnost, dostupnost, obor) definovaných názvů v rámci listu a sešitu. Jednoduše, také se pořád peru s pojmem „Definované názvy“, ale to zmíněné dělení je podle mě nesmyslné.

  4. Jde mi o to, že pod těmi definovanými názvy má excel dva naprosto odlišně fungující typy objektů.
    1) to, co zadáte tak, že to napíšete v levé horní části okna, jako je to popsané tady. Toto si Excel vytváří i sám, což je pak ta Extrakce atd.
    2) to, co zadáte pod Vložit / Tabulka. Což se naprosto liší tím, že se změní grafika, přibudou filtry a jinak se pracuje se vzorci. I tyto vložené tabulky jsou ale vidět ve správci názvů, byť s jinou ikonkou.
    Na posledním obrázku v článku jsou v seznamu obě tyto položky – je vidět, že první má jinou ikonku než druhá…

  5. Ikonky jsou mi u … začněte Jirko používat zažité pojmy… to „pole vlevo nahoře“ má taky název – Pole názvů, což je jeden z pěti pojmů, které vyžaduji i od začátečníků. Ano, Tabulky nezapadají úplně do koncepce, ostatně to je vidět třeba na stařičkém MS Query, jež na ně kašle a všímá si jen ručně definovaných názvů, nebo třeba dialog Vložit název (F3), který je také nezobrazuje. Názvy tabulek (T, KT) jsou prostě názvy objektů, stejně jako tvary atp. Ale prostě nejde tohle vytáhnout z kontextu a říct názvy máme naše nebo vložené tabulky a tečka, to tam pak musíte zahrnout vše, co název má, a vznikne z toho hromada názvů. Nemluvě o tom, že vám do toho nespadá ta kolekce „built-in“ názvů, které vytváří Excel.

  6. Jsem si dost jistý tím, že 95% čtenářů tohoto článku neví přesně, co to je „Pole názvů“, a nemyslím si, že by jim to nějak vadilo. Snažím se psát návody tak, aby byly maximálně návodné a srozumitelné, a tvrdím, že z toho, jak jsem to zapsal textem i obrázkem, je jasné, jak se buňky pojmenovávají. Vůbec nerozumím tomu, proč bych měl vedle dvou cest k pojmenování skupiny buněk uvádět všechny tvary, objekty a další.

  7. Btw, zůstanu Anonym 🙂 Jestliže nechcete sám dodržovat zavedené pojmy (byť k nim vyjádříte nesouhlas, tak jako mně se nelíbí Definované názvy) a nehodláte ani 5 základních pojmů naučit jakéhokoliv uživatele, pak k tomu nemám moc co dodat. Ano, do pytle práce, jednou zmíním malý černý čtvereček vpravo dole v buňce a řeknu, že je to vyplňovací úchyt, pak ještě dvakrát tím snadno pochopitelným dětským výrazem a pak už vždycky budu mluvit o vyplňovacím úchytu. Tomu říkám výuka. Učte klidně Excel, teda Excel ne, takový to, jak tam jsou ty čtverečky pod sebou a vedle sebe… to stačí.

  8. To je pořád dokola… účelem tohohle webu není učit někoho názvosloví Microsoftu nebo s něčím vyjadřovat souhlas nebo nesouhlas. Ani první ani druhé nikoho nezajímá. Chci psát návody tak, aby se podle nich dobře pracovalo, nic víc, nic míň. Diskusi tímto považuji za vyčerpanou…

  9. Tak doufám, že to neučíte i na školeních „pro experty“…

  10. Anonyme, mně tyhle stránky už několikrát pomohly a jsou pro mě srozumitelné. Naopak se mi nelíbí Vaše útočné komentáře na pana Berana, který se snaží jednoduše a srozumitelně podpořit začátečníky, ale i pokročilejší. Jeho způsob podání možností excelu mně baví a zkouším podle jeho návodů i další úkony, které ani v praxi nepotřebuji. Takže za mě DĚKUJI, PANE BERANE.

  11. Děkuji za Vaše ocenění Lucie, jsem rád, že se stránky líbí:) Hezký večer, JB

Napsat komentář

Vaše emailová adresa nebude publikována.

*

smazat formulářOdeslat komentář