DÉLKA / LEN – délka textu v buňce

Funkce DÉLKA slouží k tomu, abychom zjistili délku textového řetězce v textu.

Funguje velmi jednoduše. Pokud je např. v buňce A1 text "aabbcc", pak funkce DÉLKA zapsaná takto:

  • =DÉLKA("A1")

zobrazí výsledek šestku. Protože v buňce A1 je šest znaků.

Kombinace s funkcí DOSADIT / SUBSTITUTE

Tato funkce se dá zajímavě využít dohromady s funkcí DOSADIT / SUBSTITUTE v případě, že chceme zjistit, jestli se v textu vyskytuje určitý znak nebo znaky.

Pokud bychom chtěli například zjistit počet znaků "x" v textu "axbxcdefx", definovali bychom funkci takto:

  • =DÉLKA(A1)-DÉLKA(DOSADIT(A1;"x";""))

Ten zápis má docela vtipnou logiku. Nejprve zjistíme, jak dlouhý je původní text. Pak odečteme, jak dlouhý by ten text byl, pokud bychom všechny znaky "x" odstranili (nahradili prázdnými uvozovkami). Číslo, které vyjde, nám sděluje, kolik znaků "x" v textu bylo.

delka

Je také možnost zkombinovat s funkcí KDYŽ, např. takto:

  • =KDYŽ(DÉLKA(A1)-DÉLKA(DOSADIT(A1;"x";""))>0;"text obsahuje alespoň jedno písmeno x";"text neobsahuje žádné písmeno x")

resp. i zjednodušeně:

  • =KDYŽ(DÉLKA(A1)-DÉLKA(DOSADIT(A1;"x";""));"text obsahuje alespoň jedno písmeno x";"text neobsahuje žádné písmeno x")

Použití funkce DÉLKA pro rozeznání prázdných buněk

Excel má sice na rozeznávání prázdných buněk funkci JE.PRÁZDNÉ / ISEMPTY. Ta má ale tu nevýhodu, že jako prázdnou nerozezná buňku, ve které vzniká prázdná hodnota vzorcem podobným tomuto, tedy s využitím prázdných uvozovek:

  • =KDYŽ(něco;něco;"") 

Proto si můžeme pomoci tak, že v buňce vyhodnocujeme délku textu, a když vyjde nula, prohlásíme ji za prázdnou. Tedy:

  1. =KDYŽ(DÉLKA(A1)>0;"buňka není prázdná";"buňka je prázdná")

resp. i zjednodušeně:

  • =KDYŽ(DÉLKA(A1);"buňka není prázdná";"buňka je prázdná")

Napsat komentář

Vaše emailová adresa nebude zveřejněna.

Vyhledávání

Exact matches only
Search in title
Search in content
Search in posts
Search in pages
Filter by Categories
Nezařazené

Nyní otevřený kurz

Jednodenní Excel v praxi

  • 14.3.2017
  • V Praze
Další info / přihláška

Firemní kurzy

  • Přemýšlíte o firemním školení Excelu?
  • Školíme Excel od začátečníků po experty, ale také PowerPoint, PowerPivot nebo Access.
Mám zájem o kurz

Individuální výuka

Mám zájem o výuku

Vývoj aplikací v Excelu (makra - VBA)

  • Vyvíjíme aplikace pro potřeby firemních zákazníků
  • Reporty, vizualizace dat, harmonogramy, plánování
  • Slučování dat ze souborů, agregace, exporty
Zajímám se o vytvoření aplikace

Kontakt

  • Tel: +420 602 274 999
  • Mail: info@vyuka-excelu.cz
Kontaktní formulář

FB CZ

TOPlist