DOSADIT / SUBSTITUTE – funkce pro nahrazování (odstraňování) znaků v textu

Funkce DOSADIT nahrazuje v textu libovolný znak jiným znakem. Pokud chcete například v textu "abcdabcd" z buňky A1 zaměnit všechna písmena "c" za písmena "x", použijeme funkci takto:

  • =DOSADIT(A1;"c";"x")

a výsledkem bude:

  • "abxdabxd"

Argumenty

  • Prvním argumentem je tedy text, kde se má nahrazovat. Druhým argumentem co se má nahradit, a třetím čím se to má nahradit.
  • Volitelným čtvrtým argumentem je instance - pokud bych tedy chtěl nahradit pouze druhý výskyt určitého znaku, uvedu dvojku. Pokud parametr neuvedu, nahradí se všechny výskyty.
  • Pokud chci konkrétní text odstranit, nahradím ho prázdnými uvozovkami, tedy např. "DOSADIT(A1;"c";"")

Pokud chcete znaky v celé tabulce nahradit jen jednorázově, můžete použít i staré dobré Najít / Nahradit.

Funkce NAHRADIT má podobné použití jako funkce DOSADIT - ale zatímco funkce NAHRADIT pracuje s určitým místem v textu (např. se třetím znakem), tak funkce DOSADIT nahrazuje jeden určité znaky za jiné (např. nahradí jakékoliv nalezené "xx" za "yy").

8 comments on “DOSADIT / SUBSTITUTE – funkce pro nahrazování (odstraňování) znaků v textu
  1. dolly a napsal:

    nefunguje nám to 🙁 pomoc
    paní učitelka to po nás chce a nám to nefunguje 🙁 dostaneme kvůli vám za 5
    už jsme opravdu zoufalé

  2. Jiří Beran napsal:

    To musí fungovat 🙂

  3. David napsal:

    Dobry den. Lze zkombinovat substitute s funkci zprava? Potrebuji nahradit jen posledni sammohlasku ruznych slov, napriklad posledni „a“ za „o“? Muzete poradit vzorec?

  4. Jiří Beran napsal:

    Šlo by tohle?
    =KDYŽ(ZPRAVA(A1)=“a“;CONCATENATE(ZLEVA(A1;DÉLKA(A1)-1);“o“);A1)

  5. David napsal:

    Ano, presne jak jsem potreboval. Diky moc! ;o)

  6. Monika napsal:

    Dobrý den, prosím, o radu. Mám v buňce ulici například: „U květinek“ a do druhé buňky chci napsat, že se jedná o město například: Liberec.

    (Tzn., že kde mám v excelu „U květinek“, tak to znamená, že se jedná o město Liberec. Lze na tuto situaci použít „Substitute“?

    Děkuji.

  7. Anonym napsal:

    Monika – ne, na tohle se používá funkce SVYHLEDAT – VLOOKUP

  8. Monika napsal:

    Dekuji za radu.
    Monika.

Napsat komentář

Vaše emailová adresa nebude zveřejněna.

Firemní kurzy

  • Přemýšlíte o firemním školení Excelu?
  • Školíme Excel od začátečníků po experty, ale také PowerPoint, PowerPivot nebo Access.
Mám zájem o kurz

Individuální výuka

Mám zájem o výuku

Vývoj aplikací v Excelu (makra - VBA)

  • Vyvíjíme aplikace pro potřeby firemních zákazníků
  • Reporty, vizualizace dat, harmonogramy, plánování
  • Slučování dat ze souborů, agregace, exporty
Zajímám se o vytvoření aplikace

Kontakt

  • Tel: +420 602 274 999
  • Mail: info@vyuka-excelu.cz
Kontaktní formulář
TOPlist