Funkce DOSADIT nahrazuje v textu libovolný znak jiným znakem. Pokud chcete například v textu "abcdabcd" z buňky A1 zaměnit všechna písmena "c" za písmena "x", použijeme funkci takto:

  • =DOSADIT(A1;"c";"x")

a výsledkem bude:

  • "abxdabxd"

Argumenty

  • Prvním argumentem je tedy text, kde se má nahrazovat. Druhým argumentem co se má nahradit, a třetím čím se to má nahradit.
  • Volitelným čtvrtým argumentem je instance - pokud bych tedy chtěl nahradit pouze druhý výskyt určitého znaku, uvedu dvojku. Pokud parametr neuvedu, nahradí se všechny výskyty.
  • Pokud chci konkrétní text odstranit, nahradím ho prázdnými uvozovkami, tedy např. "DOSADIT(A1;"c";"")

Pokud chcete znaky v celé tabulce nahradit jen jednorázově, můžete použít i staré dobré Najít / Nahradit.

Funkce NAHRADIT má podobné použití jako funkce DOSADIT - ale zatímco funkce NAHRADIT pracuje s určitým místem v textu (např. se třetím znakem), tak funkce DOSADIT nahrazuje jeden určité znaky za jiné (např. nahradí jakékoliv nalezené "xx" za "yy").

8 Comments

  1. nefunguje nám to 🙁 pomoc
    paní učitelka to po nás chce a nám to nefunguje 🙁 dostaneme kvůli vám za 5
    už jsme opravdu zoufalé

  2. Dobry den. Lze zkombinovat substitute s funkci zprava? Potrebuji nahradit jen posledni sammohlasku ruznych slov, napriklad posledni „a“ za „o“? Muzete poradit vzorec?

  3. Šlo by tohle?
    =KDYŽ(ZPRAVA(A1)=“a“;CONCATENATE(ZLEVA(A1;DÉLKA(A1)-1);“o“);A1)

  4. Dobrý den, prosím, o radu. Mám v buňce ulici například: „U květinek“ a do druhé buňky chci napsat, že se jedná o město například: Liberec.

    (Tzn., že kde mám v excelu „U květinek“, tak to znamená, že se jedná o město Liberec. Lze na tuto situaci použít „Substitute“?

    Děkuji.

  5. Lze v seznamu najít skupiny čtyř různých cifer (pořadová čísla) a ty společně s mezerami, které jsou vždy za nimi (pořadové číslo mezera název řádku) následně vymazat (zůstane tedy pouze název řádku)? moc díky za pomoc

  6. Možná čtyřnásobné použití vzájemně vnořených funkcí SUBSTITUTE.

  7. Dobrý den, chtěl bych se zeptat, zda je možné nějakým způsobem změnit text na číslo ve funkci „DOSADIT“. Jde o to, že potřebuji napsat do buňky text (zkratu např. DV), který se v dané buňce změní na číslo (např. 5). Pokud nechám buňku s prázdnou, zůstane prázdná i buňka se samotnou funkcí.

    =DOSADIT(D4;“DV“;5)

    Po zadání funkce „DOSADIT“ se 5 v dané buňce samozřejmě objeví, ale z důvodu, že se jedná o text nelze s ní dále pracovat jako s číslem. Pokud někdo ví, děkuji za odpověď. Přeji pěkný den.

Napsat komentář

Vaše emailová adresa nebude publikována.

smazat formulářOdeslat komentář