IFNA – v případě nenalezení vrátí určitou hodnotu

Příklad

Používám vyhledávací funkci (např. SVYHLEDAT, POZVYHLEDAT...). V některých případech se ale hledaná hodnota nenajde, a pak Excel vrací vcelku nepěknou hlášku #NENI_K_DISPOZICI. Jak to tedy ošetřit?

Návod

Vyhledávací funkci obalíme funkcí IFNA. Tím zajistíme, že v případě nenalezení hodnoty se zobrazí něco jiného - například hláška "hledaná hodnota v seznamu není". Funkce pak vypadá například takto:

  • =IFNA(SVYHLEDAT(A:A;F:G;2;0);"hledaná hodnota v seznamu není")

Asi vás napadne, že stejná věc by šla řešit i pomocí funkce IFERROR. V případě vyhledávacích funkcí je ale použití IFNA čistější - protože IFERROR by pokryl i jiné chyby než nenalezeno, a výsledek nahradil jinou hodnotou. Vy byste se o chybě vůbec nedozvěděli, což obvykle nechcete.

ifna

2 comments on “IFNA – v případě nenalezení vrátí určitou hodnotu
  1. Petr K. napsal:

    Dobrý den,
    používám excel 2010, kde funkce IFNA není. Jak mohu ve starší verzi excelu vyřešit „stejný“ problém, který řešíte v tomto článku. Děkuji

  2. Jiří Beran napsal:

    Obdobně bude fungovat iferror… Přesně stejně jako ifna pak bude fungovat toto:
    =KDYŽ(CHYBA.TYP(A1)=7;“nenalezeno“;A1)

Napsat komentář

Vaše emailová adresa nebude zveřejněna.

Vyhledávání

Exact matches only
Search in title
Search in content
Search in posts
Search in pages
Filter by Categories
Nezařazené

Nyní otevřený kurz

Jednodenní Excel v praxi

  • 14.3.2017
  • V Praze
Další info / přihláška

Firemní kurzy

  • Přemýšlíte o firemním školení Excelu?
  • Školíme Excel od začátečníků po experty, ale také PowerPoint, PowerPivot nebo Access.
Mám zájem o kurz

Individuální výuka

Mám zájem o výuku

Vývoj aplikací v Excelu (makra - VBA)

  • Vyvíjíme aplikace pro potřeby firemních zákazníků
  • Reporty, vizualizace dat, harmonogramy, plánování
  • Slučování dat ze souborů, agregace, exporty
Zajímám se o vytvoření aplikace

Kontakt

  • Tel: +420 602 274 999
  • Mail: info@vyuka-excelu.cz
Kontaktní formulář

FB CZ

TOPlist