Tento článek je o skupině funkcí, jejich účelem je posoudit obsah buňky a odlišit, co v ní je - ovšem ne dle hodnoty, ale podle jiného kritéria.

Příklad

V buňce A1 jsou povolena jen čísla. V buňce B2 proto chci mít varování v případě, že v buňce A1 je cokoliv jiného než číslo.

Návod

Použiji kombinaci jedné z těchto funkcí, JE.ČÍSLO, a funkce KDYŽ. Vzorec pak vypadá takto:
=KDYŽ(JE.ČISLO(A1);"Hodnota je OK";"Pozor, chyba, ve sledované buňce není číslo!")
Jde o funkci KDYŽ, do které je vnořená funkce JE.ČÍSLO.
Funkce KDYŽ má tři parametry. Prvním z nich je funkce JE.ČÍSLO. Ta vrátí pravdu nebo nepravdu. Vrátí-li pravdu, použije funkce když druhý parametr, jinak třetí parametr.
Je-li tedy v buňce A1 jakékoliv číslo, zobrazí se "Hodnota je OK", jinak se zobrazí "Pozor, chyba, ve sledované buňce není číslo!"
Jednotlivé funkce z této skupiny:
  • JE.ČÍSLO - vrátí pravdu jen v případě, že je v buňce libovolné číslo.
  • JE.CHYBA - vrátí pravdu jen v případě jakékoliv chybné hodnoty kromě #N/A
  • JE.CHYBHODN - vrátí pravdu jen v případě jakékoliv chybné hodnoty
  • JE.LOGHODN - vrátí pravdu jen v případě, že jde o logickou hodnotu, přičemž logická hodnota je PRAVDA nebo NEPRAVDA
  • JE.NEDEF - vrátí pravdu jen v případě, že hodnota není dostupná - tedy že jde o  #N/A
  • JE.NETEXT - vrátí pravdu jen v případě, že hodnota není text
  • JE.ODKAZ - vrátí pravdu jen v případě, že v závorce je odkaz na buňku nebo skupinu buněk (např. A1:A20), jinak vrátí nepravdu (např. pokud je v buňce odkaz na text, číslo nebo funkci)
  • JE.PRÁZDNÉ - vrátí pravdu jen v případě, že buňka je úplně prázdná. Někdy se ale více hodní použít funkci DÉLKA/LEN.
  • JE.TEXT - vrátí pravdu jen v případě, že hodnota je text

Poznámka

Některé z těchto funkcí mohou být nahrazeny funkcí TYP.

2 Komentářů

  1. Proč funkce JE.PRÁZDNÉ vrátí pro interval hodnot (několik prázdných buněk) hodnotu PRAVDA, ale když ji použiji jako podmínku ve funkci KDYŽ, je vždy vrácena jen hodnota NEPRAVDA (resp. [ne])?

  2. Myslím, že je.prázdné funguje jen pro jednu buňku (resp. v případě výběru pro první buňku).

Napsat komentář

Vaše emailová adresa nebude publikována.

smazat formulářOdeslat komentář