Číslo v prvním argumentu funkce KDYŽ – možné zjednodušení vzorce

Tento článek je o tom, že prvním argumentem funkce KDYŽ / IF může být samotné číslo bez podmínky.

Předpokládejme, že chceme do buňky B1 zachytit pomocí funkce KDYŽ pravidlo:

  • KDYŽ je v buňce A1 jakékoliv číslo větší než nula, napiš "je číslo", jinak napiš "není číslo".

Takové pravidlo se dá zapsat např. takto:

  • =KDYŽ(A1>0;"je číslo";"není číslo")

ale také tímto kratším způsobem:

  • =KDYŽ(A1;"je číslo";"není číslo")

Funkce KDYŽ totiž vyhodnocuje jako pravdu nejen tvrzení, které je splněné (má hodnotu PRAVDA), ale také jakékoliv číslo různé od nuly. Číslo může být i záporné nebo desetinné, jen to nesmí být nula.

Toto se typicky použíje např. v situaci, kdy chceme určit, jestli se např. hodnota "XY" vyskytuje ve sloupci B. Vzorec vypadá takto:

  • =KDYŽ(COUNTIFS(B:B;"XY");"v béčku někde je XY";"v béčku XY není")

Vyhledávání

Exact matches only
Search in title
Search in content
Search in posts
Search in pages
Filter by Categories
Nezařazené

Nyní otevřený kurz

Jednodenní Excel v praxi

  • 14.3.2017
  • V Praze
Další info / přihláška

Firemní kurzy

  • Přemýšlíte o firemním školení Excelu?
  • Školíme Excel od začátečníků po experty, ale také PowerPoint, PowerPivot nebo Access.
Mám zájem o kurz

Individuální výuka

Mám zájem o výuku

Vývoj aplikací v Excelu (makra - VBA)

  • Vyvíjíme aplikace pro potřeby firemních zákazníků
  • Reporty, vizualizace dat, harmonogramy, plánování
  • Slučování dat ze souborů, agregace, exporty
Zajímám se o vytvoření aplikace

Kontakt

  • Tel: +420 602 274 999
  • Mail: info@vyuka-excelu.cz
Kontaktní formulář

FB CZ

TOPlist