SOUČIN.SKALÁRNÍ / SUMPRODUCT – pronásobení dvou oblastí

Příklad

V následující tabulce je seznam položek. U každé z nich je cena za kus a počet kusů. Potřebuji do buňky C15 dostat celkovou cenu za všechny položky.

uvodni_tabulka_skalarni_soucin

Návod

Mohli bychom do třetího sloupečku vynásobit vždy cenu položky a počet kusů a dole pak výsledky sečíst.

My ale využijeme funkci "SOUČIN.SKALÁRNÍ", v anglické verzi. "SUMPRODUCT".

Do buňky C15 tedy vpíšeme funkci v této syntaxi

  • =SOUČIN.SKALÁRNÍ(B2:B13;C2:C14).

Tedy nejprve název funkce a dále středníkem oddělené dva sloupečky - skalární součin tyto sloupečky vzájemně pronásobí a výsledek sečte. Výsledek vypadá takto:

skalarni_soucin_vysledek

Poznámka

U téhle funkce je trochu problém s názvem.
  • Zaprvé z anglického názvu SUMPRODUCT není moc dobře odvoditelný SOUČIN.SKALÁRNÍ.
  • A zadruhé je třeba dát pozor na pořadí dvou slov - já například docela často píšu chybně SKALÁRNÍ.SOUČIN místo SOUČIN.SKALÁRNÍ.
  • SOUČIN.SKALÁRNÍ se dá použít při počítání vážených průměrů nebo při práci s Řešitelem.
8 comments on “SOUČIN.SKALÁRNÍ / SUMPRODUCT – pronásobení dvou oblastí
  1. Lucie K. napsal:

    Dobrý den,
    trochu s touto funkcí bojuji. Potřebuji z databáze. která má cca 5000 řádků udělat účetní analýzu, takže např. potřebuji zjistit, jaké jsou náklady např. na telefon, pevnou linku, internet (tj. potřebuji sečíst hodnoty pro několik analytických účtů) u určité zakázky. Na prvním listu mám náklady vyexportované z účetního programu, na druhém listu výsledky a na třetím listu účty, které potřebuji sčítat. Pokud si zadám vzorec =SOUČIN.SKALÁRNÍ(SUMIFS(export!$C:$C;export!$A:$A;$A2;export!$B:$B;účty!A:A)), tak se mi za 2 hodiny udělá 1% přepočtu. Máte nějaký nápad jak získat informace, že na dané zakázce byly náklady na telefony tolik, na spotřebu drobného majetku tolik a pod., abych to nemusela spustit v pondělí a v pátek možná mít výsledek? Děkuji za radu.

  2. Jiří Beran napsal:

    Nevím, jestli přesně rozumím zadání a nevidím teď, proč používáte skalární součin (nestačí SUMIFS)? Nicméně pokud se pohybujete v řádech pěti tisíc řádků, tak by to v žádném případě nemělo trvat tak dlouho.
    Zkusil bych vložit všechny hodnoty do tabulky, to může hodně urychlit:
    http://vyuka-excelu.cz/navody/postupy-a-spinave-triky/tabulky-v-excelu-jak-je-vkladat/

  3. Lucie K. napsal:

    Děkuji. Zkusím se na to podívat. Bohužel SUMIFS nestačí. Potřebuji totiž např. pro každou zakázku zakázku sečíst kolik je v nákladech dohromady na účtech 518401, 518402, 518403 a 518409. V další buňce potřebuji vysčítat třeba účty 512202, 512302, 512402, 512900 a 518290 a zase pro každou zakázku zvlášť.

  4. Jiří Beran napsal:

    Aha, tak zkuste také funkci DSUMA, to by mohlo být řešení:
    http://vyuka-excelu.cz/navody/funkce/dsuma-dsum-a-dalsi-databazove-funkce/

  5. Lucie K. napsal:

    Moc děkuji. Díky Vašim stránkám jsem se s Excelem naučila vážně hodně.

  6. Roman P. napsal:

    Dobrý den,
    rád bych porozuměl použítí znaku — ve skalárním součinu. Jako takový je mi vzorec známý nicméně narazil jsem právě na užití — pro pole ve vzorci skalární součin a snažím se pochopit, proč je toto použito když to není potřeba.
    děkuji

  7. Tomáš napsal:

    Dobrý den, dostal jsem úkol.

    vyexportoval jsem data ve sloupcích a řádcích z firemního systému.
    Na druhém listu mám sečíst částky podle jednotlivých kritérií z listu 1. To znamená, sečíst firemní náklady z určité lokality za jednotlivé měsíce. používám funkci SUMIFS.
    Ale potřebuji k tomu přidat ještě jedno kritérium a to takové, že částky, se kterými bude vzorec pracovat patří pouze ke 2 samostatným účtům. To znamená, že se mi na listu č.1 vyexportují částky a měsíce ze všech lokalit a ze všech možných účtů.
    Ale já na listu č.2 potřebuji už tedy pouze sečíst data ze dvou účtů.
    Můj vzorec pro SUMIFS vypadá takto
    =SUMIFS(Export!$I$2:$I$9999;Export!$E$2:$E$9999;’Náklady po střediscích‘!E$3;Export!$F$2:$F$9999;’Náklady po střediscích‘!E$2;Export!$B$2:$B$9999;’Náklady po střediscích‘!$C4)

    potřebuji tedy do vzorce zakomponovat kritérium a to takové, že mi sečte částky pouze z účtu č.55 a z účtu 65.

    Děkuji za radu.

Napsat komentář

Vaše emailová adresa nebude zveřejněna.

Firemní kurzy

  • Přemýšlíte o firemním školení Excelu?
  • Školíme Excel od začátečníků po experty, ale také PowerPoint, PowerPivot nebo Access.
Mám zájem o kurz

Individuální výuka

Mám zájem o výuku

Vývoj aplikací v Excelu (makra - VBA)

  • Vyvíjíme aplikace pro potřeby firemních zákazníků
  • Reporty, vizualizace dat, harmonogramy, plánování
  • Slučování dat ze souborů, agregace, exporty
Zajímám se o vytvoření aplikace

Kontakt

  • Tel: +420 602 274 999
  • Mail: info@vyuka-excelu.cz
Kontaktní formulář
TOPlist