Náhodné zařazení položek do výběru

Příklad

Při vědeckém zkoumání někdy potřebujeme vytvořit výběr, který je zcela objektivně náhodný. Jak to udělat v Excelu? Představte si, že máte patnáct položek (v našem případě objekty od jedné do patnácti) a potřebujeme zcela náhodně vybrat tři.

Návod

Nejprve každé z těchto položek přiřadíme náhodnou hodnotu pomocí funkce NÁH.ČÍSLO.
 1 náhodné číslo
Pak do dalšího sloupce určíme pomocí funkce RANK pořadí tohoto náhodného čísla a rovnou toto pořadí porovnáme pomocí funkce KDYŽ s počtem objektů, které chceme do výběru zařadit. Např. takto: =KDYŽ(RANK(B2;B:B)<=$A$19;"vybrat";"nevybrat") 2 kombinace náhodného čísla s if a rank Roztáhneme a u každého objektu vidíme, jestli je do výběru zařazený nebo není. Po stisku klávesy F9 se tento výběr určí vždy znovu.
3 hotovo
2 comments on “Náhodné zařazení položek do výběru
  1. LG napsal:

    Dobrý den, jak by vypadal tento příklad pokud by každý „objekt“ měl ještě v dalším sloupci hodnotu a já chtěl náhodně vybírat do doby než bude součet těchto hodnot náhodně vybraných objektů roven určité sumě?

  2. Jiří Beran napsal:

    V tom případě buď můžete nechat makro, aby to pořád zkoušelo, nebo raději zkusit Řešitele – ten právě zkouší hodnoty dokud neodpovídají výsledku.
    http://vyuka-excelu.cz/navody/resitel-a-jeho-vyuziti/

Napsat komentář

Vaše emailová adresa nebude zveřejněna.

Firemní kurzy

  • Přemýšlíte o firemním školení Excelu?
  • Školíme Excel od začátečníků po experty, ale také PowerPoint, PowerPivot nebo Access.
Mám zájem o kurz

Individuální výuka

Mám zájem o výuku

Vývoj aplikací v Excelu (makra - VBA)

  • Vyvíjíme aplikace pro potřeby firemních zákazníků
  • Reporty, vizualizace dat, harmonogramy, plánování
  • Slučování dat ze souborů, agregace, exporty
Zajímám se o vytvoření aplikace

Kontakt

  • Tel: +420 602 274 999
  • Mail: info@vyuka-excelu.cz
Kontaktní formulář

Nejnovější komentáře

TOPlist