Dohledávání hodnot z dvourozměrné tabulky – POSUN, POZVYHLEDAT, SVYHLEDAT

V tomto návodu si ukážeme, jak získávat data z tabulky, která je dvourozměrná. 

Místo vysvětlování se však raději hned podívejme na příklad. V následující tabulce potřebujeme k jednotlivým výrobkům přiřadit jejich cenu - podle toho, o jaký výrobek a jakou verzi se jedná.

V článku jsou ukázané dva způsoby jak dosáhnout výsledku.

Použití kombinace funkce POSUN a POZVYHLEDAT.

matice

Použijeme kombinaci funkcí POSUN / OFFSET a POZVYHLEDAT / MATCH. Zapíšeme ji takto:

  • =POSUN($F$1;POZVYHLEDAT($B:$B;$F$2:$F$6;0);POZVYHLEDAT($C:$C;$G$1:$I$1;0))

Zápis je dlouhý, ale vlastně ne příliš složitý. Prostě funkcemi POZVYHLEDT zjistíme souřadnice, na které se má POSUN podívat. Soubor ke stažení tady. matice

Použití kombinace SVYHLEDAT/VLOOKUP a POZVYHLEDAT

Pokud raději než s POSUNem pracujete s funkcí SVYHLEDAT, možná oceníte alternativní postup. V něm funkce POZVYHLEDAT najde, ve kterém sloupci se vyskytuje které záhlaví, výstup poskytne funkci SVYHLEDAT, ta se dozví, do kterého sloupce se dívat, a vrátí hodnotu.

  • =SVYHLEDAT(B:B;F:I;POZVYHLEDAT(C:C;$F$1:$I$1;0);0)

Srozumitelněji na obrázku:

svyhledat pozvyhledat

Napsat komentář

Vaše emailová adresa nebude zveřejněna.

Firemní kurzy

  • Přemýšlíte o firemním školení Excelu?
  • Školíme Excel od začátečníků po experty, ale také PowerPoint, PowerPivot nebo Access.
Mám zájem o kurz

Individuální výuka

Mám zájem o výuku

Vývoj aplikací v Excelu (makra - VBA)

  • Vyvíjíme aplikace pro potřeby firemních zákazníků
  • Reporty, vizualizace dat, harmonogramy, plánování
  • Slučování dat ze souborů, agregace, exporty
Zajímám se o vytvoření aplikace

Kontakt

  • Tel: +420 602 274 999
  • Mail: info@vyuka-excelu.cz
Kontaktní formulář
TOPlist