Řešení soustavy rovnic Řešitelem

Příklad

Potřebuji vyřešit soustavu rovnic jako je například tato:

2x - y -8z = 4 -x +y +5 = -4 -2 -1 +2 = 8

Návod

Použiji Řešitel. O tom více tady. Připravím si tabulku s levou stranou rovnic a do sloupce pravé strany, např. takto:

rovnice_resitel

Ve sloupci E spočtu levé strany rovnice pomocí funkce SOUČIN.SKALÁRNÍ.

rovnice_resitel2

Každý řádek soustavy takto pronásobím s posledním čtvrtým řádkem - ten je zatím prázdný, ale později v něm získám řešení. Např. v buňce D1 funkcí 

=SOUČIN.SKALÁRNÍ(A1:C1;$A$4:$C$4)

pronásobím první rádek čtvrtým. Spustím řešitel a nastavím ho takto:

resitel_rovnice

Levou stranu jedné z rovnic (je jedno kterou, já jsem si vybral první) optimalizuji na hodnotu z pravé strany. U ostatních to zařídím podmínkou. Další podmínkou zařídím že se i u dalších rovnic rovnají levé strany (skalární součiny) s pravými stranami. A pak už jen nechám řešit. Možná bude třeba ve volbě Možnosti trochu zvýšit citlivost - aby Excel opravdu dopočítal celá čísla. Výsledek je takovýto:

resitel_hotovo
Zjistil jsem, že x = -6, y = 0 a z = -2.

Příklad je tady: soustava rovnic

3 comments on “Řešení soustavy rovnic Řešitelem
  1. Honza napsal:

    V řádku zadání:

    >>>2x – y -8z = 4 -x +y +5 = -4 -2 -1 +2 = 8<<>>Ve sloupci E spočtu levé strany rovnice pomocí funkce SOUČIN.SKALÁRNÍ.<<<

  2. Jiří Beran napsal:

    Nerozumím…?

  3. Jarda napsal:

    V řádku zadání chybí u třetí rovnice proměnné

Napsat komentář

Vaše emailová adresa nebude zveřejněna.

Firemní kurzy

  • Přemýšlíte o firemním školení Excelu?
  • Školíme Excel od začátečníků po experty, ale také PowerPoint, PowerPivot nebo Access.
Mám zájem o kurz

Individuální výuka

Mám zájem o výuku

Vývoj aplikací v Excelu (makra - VBA)

  • Vyvíjíme aplikace pro potřeby firemních zákazníků
  • Reporty, vizualizace dat, harmonogramy, plánování
  • Slučování dat ze souborů, agregace, exporty
Zajímám se o vytvoření aplikace

Kontakt

  • Tel: +420 602 274 999
  • Mail: info@vyuka-excelu.cz
Kontaktní formulář
TOPlist