Příklad

Při vědeckém zkoumání někdy potřebujeme vytvořit výběr, který je zcela objektivně náhodný. Jak to udělat v Excelu? Představte si, že máte patnáct položek (v našem případě objekty od jedné do patnácti) a potřebujeme zcela náhodně vybrat tři.

Návod

Nejprve každé z těchto položek přiřadíme náhodnou hodnotu pomocí funkce NÁH.ČÍSLO.
 1 náhodné číslo
Pak do dalšího sloupce určíme pomocí funkce RANK pořadí tohoto náhodného čísla a rovnou toto pořadí porovnáme pomocí funkce KDYŽ s počtem objektů, které chceme do výběru zařadit. Např. takto: =KDYŽ(RANK(B2;B:B)<=$A$19;"vybrat";"nevybrat") 2 kombinace náhodného čísla s if a rank Roztáhneme a u každého objektu vidíme, jestli je do výběru zařazený nebo není. Po stisku klávesy F9 se tento výběr určí vždy znovu.
3 hotovo

2 Komentářů

  1. Dobrý den, jak by vypadal tento příklad pokud by každý „objekt“ měl ještě v dalším sloupci hodnotu a já chtěl náhodně vybírat do doby než bude součet těchto hodnot náhodně vybraných objektů roven určité sumě?

Napsat komentář

Vaše emailová adresa nebude publikována.

*

smazat formulářOdeslat komentář