Tento článek je o tom, co to je vážený průměr, a jak se počítá logicky i jak se počítá v Excelu. Na tomto webu je i článek o běžném aritmetickém průměru a článek o klouzavém průměru.

Modelová situace pro počítání váženého průměru

Firma vyrobila tři zásilky s různými počty výrobků a různým procentem chyb.

vyrobky

Otázka je - kolik procent byla celková chybovost?

Pokud bychom použili standardní aritmetický průměr, zprůměrovali bychom čísla 5%, 36% a 9%. Výsledkem by bylo 16,66%. Je zřejmé, že to je nesmysl. Průměr byl velmi ovlivněn druhou zásilkou, která měla sice vysokou chybovost, ale byla v porovnání s ostatními zanedbatelně malá.

Smysluplnější číslo dostaneme, pokud použijeme místo běžného průměru průměr vážený, přičemž jako váhy použijeme velikosti zásilek. 

Jak na to jít s kalkulačkou

Pokud bychom nechtěli využít Excel, nejprve bychom si pronásobili váhy chybovostí:

bez excelu

Pak bychom sečečetli hodnoty ve třetím sloupci tabulky (násobky), a vydělili bychom je celkovou velikostí dávky. 

(70+4,8+108)/(1400+30+1200)=0,0695=6,95%

Je zřejmé, že takovýto průměr mnohem lépe vypovídá o tom, jaká byla celková chybovost všech zásilek dohromady.

Jak počítat vážený průměr v Excelu

I v Excelu bychom samozřejmě mohli násobit a sčítat. Rychlejší ale bude využít funkci SOUČIN.SKALÁRNÍ a všechno sfouknout jedním vzorečkem, např. tímto:

  • =SOUČIN.SKALÁRNÍ(A2:A4;B2:B4)/SUMA(A2:A4)

součin skalární

Skalární součin nejprve pronásobí váhy a hodnoty, všechno se pak vydělí součtem vah. Výsledek je stejný jako předtím.

Napsat komentář

Vaše emailová adresa nebude publikována.

*

smazat formulářOdeslat komentář